Gps-speedsurfing

i'm trying to update my gt31 from V1.2 to V1.4 803. when i try to execute the 1.4boot, gt31updater says i need a password. the password is right in that screen but when i copy that password, it says bad or expired password

can anyone help me out with this?

ZFINS