Gps-speedsurfing




I am having real problems updating my GT31.  When I purchased my GT31 my pc ran on XP, this has now been replaced and the system works on Windows 7, Windows 7 does not like the installation disc and when I try and install the driver as per the instructions I get the following box PL-2303 Vista Driver Installer - Install shield wizard displaying the message "do you want to completely remove the selected application and all of its features - Yes/No"  The no button does not work and I have to use Task Manager to exit.

I have been told that windows 7 will still work without the driver however when I attempt after 95% of transfer I get the following message "firmware update failed exit code 1".

My GT31 is a bluetooth version so I attempted to do the update using bluetooth, connection continuity and comports were checked but the same message "firmware update failed exit code 1" is displayed.

I have a laptop which still works on XP I went through the process on this and get the same message.  I uninstalled the driver on this machine as the installation CD appears to work I reinstalled the driver, restarted and attempted yet again.  Same message "firmware failed etc" was displayed.

I must say that the switch I have to operate is extremely difficult to see whether this is because it is a bluetooth version I am not sure, the white mark as per the instructions is not obvious, there are only two small white lines and I assume that the switch is lined up with these to the right with the display face down.

When I browse for the file on either computers there is a tick box indicated as "open as read only" which is ticked - do I leave this ticked or untick?  I have tried both and neither work.

The USB lead to the unit appears to work as it works both when used with the mains charger and charges the unit when connected to the computer.

Can anyone tell me what I am doing wrong?

Richard Haynes 
Richard,
I'm willing to help you via a remote desktop session if you keep having these problems.
You can contact me via email raymond at gps-jadajadajada

Raymond
Raymond
Thanks for the offer I am still trying different things and if I fail I will contact you.

I was not sure whether the cable was fully functional however I have connected the GT31 unit to my laptop which has Navilink 11 installed, the unit talks to the Navilink programme and exchanges data I therefore believe that the USB cable is OK. Does this mean that the driver is working OK as well?  I have now checked the cable, the com ports, the driver so I am starting to believe that the unit itself is at fault, it could be that there is minor corrosion on the switch inside the unit. Does anyone else have any other ideas or suggestions.

Richard
Hello Richard,
  Me and Norman managed to update my two tonight. We updated to version 1.3 with the older installer before updating to 1.4 with the new installer and the switch method.  We had a few hicups along the way and had the failed 'the exit code 1 ' message a few times.
  Norman has listed all our moves so it wouldnt be a bad idea to contact him. We used xp and did get there in the end I think two heads were better than 1. To use the new navi updater v071 we had to remove the old one completely first dont know whether this would help. Must shut up now as I am definately no computor guru. 
Hello Pete

Thanks for your update, it is somewhat reassuring (and also an experience bit of guilty pleasure) that others are having problems and it is now just down to my ineptitude.

I left a message on the Locosys website last evening and received a very helpful reply this morning.  They have suggested I download the driver intended for Windows 7 which is not apparent on the Mount Best website, the link to this is -

http://www.locosystech.com/download/driver/PL-2303_DriverInstaller_v130.zip they also say that the Navilink has been updated and the link for this is

http://www.locosystech.com/download/handheld/GT-31/NAVILINK_Installer_V250_B0826A.zip

I will not be able to try to update as I am away for a week however I will let you knowhow it goes when I return.
It would appear that there are problems with the update, on one of my machines it was the first time that I downloaded the installer so it was not confusion between the old and the new. I also tried to download version 1.3 but this failed and I got the same error message.

Locosys have asked if I fail with the new process to let them know when and where I purchased the unit, it could be that they suspect that there is a batch that will be difficult to update.

Richard

If it is any help I had no end of problems with Vista, I tried many times to update from 1.2 as the new updates came online. A few months back I just connected it through my works laptop with XP and it did it straight away. It may be something to do with the installer not cleaning itself off Vista, I cannot comment on that as I have never installed the installer (!?!?) on the XP laptop.
Returned from week away deleted all previous versions of updates from my pc which runs on Windows 7. Downloaded the recommended files from the Locosys website and followed the procedure recommended by Pete Young - updated to version 1.3 - success. After two attempts to update to 1.4 -  success.  I suspect the problem was partially because of incompatibility with Windows 7 but this was solved by downloading the new driver from the website.  Why it did not work with XP I cannot explain.

I must say that the speedy response and help I got from Locosys was first class.

Richard
KATER