Gps-speedsurfing
Howdy y'all.

I've recently purchased a GT31 unit and I am experiencing a few problems getting the data from the unit to my PC.

Here is the wierd thing. First time I tried it it worked like a charm. I turned the unit on, entered navilink mode and I could save the data without any problems.

Now its quite a different matter. I have had a so-so session on the water today and wanted to grab the data and get accustomed with the unit and such, but when I try to download the data from the unit I'm confronted with a 'error 134', ERROR_NO_DEVICE_DETECTED - Switch Navi on and activate NaviLink-mode.

So that's it, I have no idea what is wrong, why it worked like a charm the first time I downloaded data from the unit, and why it is obviously not working now.

Any help much appreciated!

Frederik,

Have you got an SD card reader ? If so you can:
  • Remove the SD card from the GT31 and pop it in your card reader.
  • Copy the data file from the SD card somewhere onto your hard drive.
  • Load up GPSResults and then use menu 'File / Open' , navigate to directory on your hard drive where you copied the file, select your file and click on the 'Open' button.
Ta, Mark
Hi Frederik,
did you use the navilink software the first time when connected or gpsresults?
in gpsresults you have to choose the right com-port, NOT! usb, since the unit ha a built-in serial to usb-converter.



hope this helps,

thorsten
forgot to mention that the device has to be in navilink mode of course...
Unfortunately I have no card-reader.

Jup, it's in Navi-Link mode, and I'm transferring the data through the usb.

I used the usb/navi-link the first time too.

Ok, still no luck getting the data to the PC. I thought I would try to go through my actions step by step, and hopefully someone of you folks will be able to pinpoint the problem.

 

First of all, the GT31 unit was bought from Riks in the UK, so it should come with speed-settings and updated firmware.

 

I went though the unit and wrote down any settings and such that I could find. Im sure that a lot of them are completely useless in locating the problem, but one cant be too sure J

 

Firmware: v1.2 (B0922)

 

Settings:

Language – English

Time Zone – Europa

Unit – Meter

Time Format – 24h

Date Format – dd/mm/yy

Arrived – 10m

Map Datum – WGS84

Position – dd/mm/ss.s

User Grid – L=E102 S=1.000000 X=500000 Y=0

Power Mode – Normal

DGPS Source – Off

Interface – Binary

Backlight – On

Backlight Time – 10 Seconds

Contrast - ???

Ext. Power Mode – Off

Username – Malloy

Usage – RTE:0/20 WPT 0/1000

Speed Avg Time – 10 Sec

Speed Genie – 20 kmh

Hold Key – Key Lock

Serial # - XXXXXXXXX

 

Misc:

Calendar – 23/09/2009

Screen Flip - Off

Reserved – C0:B426

Reserved – C0:B426

 

Memory Card:

Log Switch – On-Fix

Min Speed – 1 kmh

NMEA Items – SBN

File Size – Card Size

Format Card – Fat 16

Remove Card – 1mb/1902mb / 23285B (SNB)

 

Data Logger:

Interval – 1 Sec

Min Speed – 1kmh

Save to Card – 7248/20480   / 245(SBP)-0-0

Clear – 7248/20480   / 245(SBP)-0-0

 

 

Now to the handling:

 

A: Turn on GPS and wait for sattelites to be located.

B: Lock the keys by holding down the stick.

C: Surf

D: Turn off GPS and go home.

E: Turn on GPS, insert USB-cable in GPS, then in PC.

F: Enter ‘Navi-Link’ mode

G: Start up GPSResults

H: Choose ‘Load trackpoints’ – Settings GT11/31 ????

I: Choose name for file being saved

 

PROBLEM!!!

GPSResults pop-up window with the following message:

 

Error 134 during execution of ‘”c:\Program Files(x86)\GPSResultsV6\nkv.exe” –C 7 –X’:

ERROR_NO_DEVICE_DETECTED

 

Then…

 

Switch Navi on and activate Navilink-mode!

 

Then…

 

Track-start could not be found!

There I am, I got data from the unit the first time I tried a week or so ago, but now no luck.
As far as I can tell Im choosing the right com-port and everything too.

Thanks y'all in advance :)

Hi Frederik, the latest firmware version is V1.2(B1405x), however, I guess your problem has more to do with the interface setting: it should read NMEA and not BINARY,,,
Thanks Manfred, I will try that out tomorrow, ride the bike a bit and see if I can make it work.

I'm guessing that the problem could be connection via the USB, that the plug or cable is defect. I did try another cable and no luck. Also, am I doing it right when I just turn on the unit, sail, then attempt to grab the data? Would I need to save the data to the SD-card or something (I'm assuming that this is done automatically)?

So many questions :)

I'll write again as soon as I have tested the NMEA-setting.

Thanks for the help so far guys, much appreciated! :)
Frederik,

as somone already mentioned above: buy yourself a SD-card! Everything is much easier if you start using one.

The GT31 saves the data both in its internal memory and on the SD-card. And if the SD-card failes to record data, you can always use the "Save to card" feature in the memory logger screen. A SD-card is mandatory in the swedish events, for instance.

A top tip is to assign the .sbn extension to GPSResults in Windows. Then you can just double-click the files in the explorer.

/Jesper
Hey Jesper!

I am sorry for the confusion, my GT31 is equipped with a 2gb SD card already.

Are you saying that when I use the USB-cable, the PC connects with the internal memory on the GT31 and NOT the SD-card? If that is the case I should (short of charging the damn thing) throw away the USB-cable, and get a card-reader?
Hi Frederik,
You might find some useful information in this link

http://www.seabreeze.com.au/forums/topic.asp?TOPIC_ID=52673

Yes, it appears the easiest way to use the GT-31 is not with the cable and Navi-link (which to me would seem like the most logical way)  But instead after every time using it, remove the SD card, and transfer the data using a card reader.

Wouldn't it be nice if you could just come back from windsurfing and plug the unit in via the usb cable to download?!
A cardreader is only 5,- euro....and your problem is solved.
Hi,
my unit is also set to interface mode binary (which imho is the setting for the data sequence transmitted using the device as a "gps-mouse") and works with gpsresults (5.50) like a charm.
the problem will be the com-port-setting in gpsresults. you have to choose the right one in the scroll down list, you can do so by trial and error. ("com1 serial"normally is the built-in port of the pc) on one of them it will connect, on my office machine it is e.g. "com9 serial".

best regards, thorsten

p.s. (off topic) manfred, do you know something about the new firmware version with pwr-button problem fixed? (basil mentioned it on another thread)
Hey again! :)

@Craig: I may be spoiled, but on my Garmin Forerunners 205 the data is transferred just that way, very practical.

@Dylan: I purchased a couple of different card-readers online today, I'll have them in a day or two.

@Thorsten: The issue with the different COM-ports is not a problem, I've checked it every time and its the right one.
I may also try out the binary setting again to see if that is a success.

Thanks again y'all for helping out, hopefully I'll get this sorted out so I can stop worrying about losing my sessions :)
Frederik: Yes, throw away that cable and get yourself a card reader!! Well do not throw it away because you need it to charge the battery. You can't even transfer anything from the SD card with the USB-cable, only from the internal memory. And you will find that it is a *lot* more practical to just open the file on the SD-card...
You seem to be danish. Then you should be able to read swedish? If so, jump to this link for tips and tricks with your GPS: http://www.surfzone.se/forum/showthread.php?t=57774

/Jesper
@Jesper: Thanks on the info on the USB-cable, I was starting to suspect that the navilink-usb-thingie only connected to the internal memory of the unit.

I am indeed able to read swedish as I've gone to school there. Also the fact that I married a Swede helps I guess ;) I'll take a look at the steffo-link you provided.

Btw: I tried to grab the data again last night through the USB, no luck at all... I wonder if it was just complete luck when I managed to do it the first time. Anywho, I should recieve my card-readers in the mail today, then I'll know if everything works.

Thanks again for the input! :)
Got my two (can you ever have enough hardware?) card-readers today and... WOW... it's... so... simple... now...

I just grabbed all the data from the SD card and placed it on my hard drive! USB-cable will from now on be used only for powering up the GT31!

I have one more question though, in regards to the file extensions on the SD card; I've encountered 3 types of files in the SD card, but I'm a bit uncertain of what is what, and why. The file types are .SNB, .SBP and .SPD

Why is the data saved in different file types, I'm in the dark here :)

Thanks again y'all! :)
A follow-up question, connected to the file extensions I believe.

Manfred mentions that the unit should be set at NMEA and not BINARY. What is the difference?
Frederik,

"USB-cable will from now on be used only for powering up the GT31!"

Unless someone can tell me otherwise you'll still need the USB cable and have Navilink installed on your PC to upgrade the firmware on your GT-31.

Ta, Mark
@ Mark: You are absolutely correct! I actually updated the firmware last night, using the USB-connection. So, I would throw away the USB-cable if it wern't for the 1: charging 2: Firmware update, reasons :)

It amazes me that the BlueTooth version of the GT31 cannot be used to move he data from the SD-card to a computer, I mean, why not use the function for something that's actually useful?

On the nerdy side, would it be possible to make the BlueTooth function work for transferring data to a computer via updated firmware at a later point, or is that impossible? I know I would buy a BlueTooth version if this was an option :)
Hi there,
Im new to the GT-31 and am experiencing the very same problems described in this thread. I have a Transcend 2GB SD card but the GT-31 doesnt seem to like it.  When I put it into the unit I get a pop up screen saying bad format and when I go to the memory card section and try to format the card I get another pop up screen saying stop log first. Whats that all about then?
Ive been trying to read up about it and it seems to me that the SD card I have should be compatible with the unit, is this the case or do I need another card? If I do can someone please tell me which types/brands will work.
Cheers.
you have to stop the process of logging trackpoints to your sdcard first, otherwise it is in use.

go to sdcard menu -> select log switch and set it to off
format sdcard
put the logswitch option back to on

Thanks Dylan,
Problem sorted.
I have had the same error pop up now and then even with the correct port. I have not used a SD card with my unit. What I do is just unplug the unit from the usb, turn off the unit and close the Navilonk on the desktop and start over and that takes care of it
IFINS