Gps-speedsurfing

@all,

Last week again the issue with problems displaying full sessions tracks on Google Maps (Premium Members only) was reported again by Pat Erauw. For months we have tried to find the solution for this, and we are happy to announce that we think we have found the root-cause... We assumed that incidents related to track-display where caused by poor performance on the client side and latency issues related to the Google Maps Webservices but last week we did again some additional test and we finally managed to isolate the problem.

It appearded only sessions posted with GPSAR Pro Version 5.10 & 5.11 were affected (approx 30% session posted in the recent months), some session data related to track-display only seemed to be exported in a bit different format than in previous versions of GPSAR Pro. Today Dylan has released a small fix on the website, so from now on any session posted with GPSAR Pro should be displayed correct.Unfortunately it's not possible to apply this fix to sessions posted before today, so when opening historical sessions posted with GPSAR Pro 5.10 or 5.10 we still have this issue. 

We have informed the developer of GPSAR Pro about this situation, and expected that a software-fix will be deployed to fix this also for future releases. 

 

Please keep up posted about the results....

 

GPS Crew

Thanks for the in-depth explanation and thanks for the positive action ! Will keep an eye on track display and inform about the average user-perceived rate of sessions succesfully displaying tracks. Pat 

Yes, major improvement indeed. Sessions at Herkingen 13/10/16 tracks now displayed in approx. 15/20 sessions. This is about 75% success  rate compared to previously 10%. Sessions not displaying tracks are for non-GT-31 only devices (Canmore, TomTom, Garmin etc.). Discovered awesome Grevelingen touring track around Hompelvoet by Dennis Klaaijsen. Discovered Gouwzee distance track by Remco cas, reaches of 4-5kms. Nice !

One more remark: during track display (which takes sometimes > 1 minute depending on distance), the entire site is halted, on all clients, both client pc requesting track display as other pc's. It seems that the track display function waits modally until the Google Maps server request is finished. Would it be possible to make this non-modal, so that the site is still responsive while waiting for the track to display ?

Thnx for the possitive feedback and good to hear that the irmprovements are visible. We have noticed this secondary issue also, we have some ideas about this to fix, will take some additional time... but it wlll be on the worklist...

@pat: I have recovered the tracks from oktober and september, could you double check if it is correct and if that is the case I 'll do it also for older tracks.

I will look into the 2 other items (fit files and async also)

Yes, opened at random 15-20 sessions from sep+oct, tried to select riders that I remembered not showing tracks since a while, now most display, thanks !

 

Thanks, than I will do this for the other months also.

That would be very nice, thanks. Always interesting to see where Mr. "Hour" Pellen sets his tracks.

STARBOARD